Problems with UPS 3.33 and g++ V2.8.1

From: Stu Lewin (lewin_at_isd93.mcgi)
Date: Tue Feb 02 1999 - 22:07:46 GMT


I'm trying to use the latest (according to your website) of UPS with
g++ version 2.8.1 (C++ code; using templates if that matters) and when
I try to load an executable I get a core dump with a segmentation
violation. I notice the web page only lists support through gcc 2.7.2.

I wondered if anyone else has had this problem (so I know it's not
something peculiar to what I'm doing 

And more importantly, is there support planned for the later g++. I
love UPS and hate to have to find another debugger (or go back to
using xxgdb).

Please reply to me directly (as well as anything you send to the list)
as I'm not subscribed yet ... so I apologize if this is a frequent
question. I should probably get on the list ... but right now I'm just
trying to meet a deadline.


<slewin_at_peridot:412> /local/tools/bin/ups-3.33-solaris-2.5 -V
ups version 3.33 (build date: Wed Sep 30 17:39:55 PDT 1998)

Library versions:
        arg version 1.26 (build date: Sun Jun 4 22:40:57 BST 1995)
        obj version 1.36 (build date: Sun Jun 4 22:40:13 BST 1995)
        edit version 1.17 (build date: Tue Jun 20 22:57:59 BST 1995)
        Men3wn version 1.34 (build date: Sun Jun 4 22:38:13 BST 1995)
        mtrprog version 1.41 (build date: Sun Jun 4 22:26:40 BST 1995)
        ukcprog version 1.22 (build date: Tue Jan 10 10:03:27 GMT 1995)
        wn version 1.86 (build date: Sun Jun 4 22:32:12 BST 1995)

Target drivers: 
        C interpreter output files
        C source files
        Native support for solaris-sparc ELF object files
<slewin_at_peridot:413> g++ -v
Reading specs from /local/tools/gcc/2.8.1/lib/gcc-lib/sparc-sun-solaris2.5.1/2.8.1/specs
gcc version 2.8.1

This archive was generated by hypermail 2.1.4 : Wed Feb 13 2002 - 21:51:32 GMT